Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-1063

Dependency on unsupported jdbc-postgresql version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      2
    • Documentation Status:
      Needed

      Description

      dependencyManagement in the parent POM specifies PostgreSQL driver version 8.1-408.jdbc3. 8.1 is nearly five years old and considered "archived", and this version is not even as recent as the archived 8.1. Today the oldest supported version is 8.2-512 and the closest to that in Maven Central is 8.2-511; the current release is 9.1-901 and the closest in Maven Central is 9.0-801. I'd like to suggest testing with 9.0-801.jdbc4 since we require at least JVM 1.6 and JDBC4 is recommended for use with that version. (All this information about the driver is from http://jdbc.postgresql.org/download.html and the Maven Central record is at http://search.maven.org/#browse|2006313248)

        Attachments

          Activity

            People

            • Assignee:
              mwood Mark H. Wood
              Reporter:
              mwood Mark H. Wood
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: