Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-1587

Update 1.7.x and 1.8.x branches for Git/GitHub

    Details

    • Type: Code Task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1, 1.8.2
    • Fix Version/s: 1.7.3, 1.8.3
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      2
    • Documentation Status:
      Needed

      Description

      Since our code migration to GitHub (see DS-1150) in 2012, we never actually backported GitHub related settings (in Maven, etc) to older branches of DSpace.

      We should backport the following to 1.7.x and 1.8.x (for users who are still on those versions):

      • All Git/GitHub related pom.xml settings & remove all old SVN related settings
      • .gitignore and .gitattributes
      • The merger of the old 'dspace-pom' module into the 'dspace-parent' POM (as we no longer maintain the old 'dspace-pom' module). This includes:
      • Backporting the latest License Header checking functionality (maven-license-plugin) & POM settings.

      I've already pretty much got this working for 1.8.x. So, a Pull Request should be coming soonish.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tdonohue Tim Donohue
                Reporter:
                tdonohue Tim Donohue
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: