Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-1587 Update 1.7.x and 1.8.x branches for Git/GitHub
  3. DS-1588

Update 1.7.x branch to build properly with Maven 3

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7.0, 1.7.1, 1.7.2
    • Fix Version/s: 1.7.3
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      1
    • Documentation Status:
      Needed

      Description

      The 1.7.x branch (in GitHub) doesn't build properly with Maven 3.

      We should work to backport the changes added in DS-881 (which were applied in 1.8.x branch) to allow 1.7.x to build in recent versions of Maven.

      This also means that the 1.7.x branch will need to be updated to support the "Full Build" and "Quick Build" options which were added to 1.8.0 (as part of DS-881). Those options are described in the 1.8.x docs here:

      https://wiki.duraspace.org/display/DSDOC18/Advanced+Customisation#AdvancedCustomisation-DSpaceSourceRelease

        Attachments

          Activity

            People

            Assignee:
            tdonohue Tim Donohue
            Reporter:
            tdonohue Tim Donohue
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: