Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-2114

Mirage 2 requires Maven 3.0.5 or above

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: XMLUI
    • Labels:
    • Attachments:
      0
    • Comments:
      3
    • Documentation Status:
      Needed

      Description

      The new Mirage 2 feature (DS-2052) in DSpace 5.0 currently requires Maven 3.0.5 or above. This is because the iterator-maven-plugin (which is used heavily by the Mirage 2 build process) requires Maven 3.0.5:
      https://github.com/khmarbaise/iterator-maven-plugin

      Currently some major OS'es are not yet updated to Maven 3.0.5 (e.g. on Ubuntu 12.04LTS the latest Maven version is 3.0.4). Since Mirage 2 is disabled by default (optional), it'd be nice if we didn't need to require Maven 3.0.5 for DSpace 5.0.

      There are two ways to resolve this ticket:
      1. Find a way to get Mirage 2 to build on Maven 3.0.4 (if possible)
      2. If #1 is not really possible, just bump up our Maven version requirement to 3.0.5 for DSpace 5.0

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tdonohue Tim Donohue
                Reporter:
                tdonohue Tim Donohue
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: