Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-2249

Tomcat 7 JSP compiler Jasper defaults to Java 6

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 5.0
    • Fix Version/s: 5.0
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      6
    • Documentation Status:
      Complete or Committed

      Description

      Apparently jasper the jsp compiler of tomcat default compiles to java 6.

      http://stackoverflow.com/questions/19674097/netbeans-will-not-treat-jsp-as-source-level-7

      I don't think it is a good idea to have a difference in source level between java code and the jsp's. That will bite you later.

      I am not quite certain if we can enforce it in dspace itself.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rdillen Roeland Dillen
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: