Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-280

build.xml fails for ant versions below 1.7 (patch included)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: 1.6.0
    • Component/s: DSpace API
    • Labels:
      None
    • Environment:
      linux/java1.5/ant 1.65
    • Attachments:
      1
    • Comments:
      3

      Description

      build.xml uses the <intersect> tag which is only available in ant 1.7. The doc says "any version of ant 1.62 or later", although 1.65 seems to be the requirement I remember.

      Changed the fileset to use <and> instead of intersect of filesets; patch attached.

      This may only be an issue when you run ant -Doverwrite=true update with ant < 1.70.

        Attachments

          Activity

            People

            • Assignee:
              jtrimble Jeffrey Trimble
              Reporter:
              lcs Larry Stone
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: