Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-3315

Update mirage 2's building dependencies (nodejs/npm)

    Details

    • Type: Code Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.0
    • Fix Version/s: 6.0
    • Component/s: XMLUI
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      16
    • Documentation Status:
      Complete or Committed

      Description

      I noticed the following warnings during a build of mirage 2 on Travis CI:

      npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
      npm WARN deprecated tough-cookie@0.12.1: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
      
      npm WARN deprecated graceful-fs@2.0.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
      
      npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm
      

      The task here is obvious: we need to update the dependencies. Most probably these dependencies are used only for building mirage 2 and not in production.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pbecker Pascal-Nicolas Becker
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: