Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-3419

Mirage2: Handlebars version conflict

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 6.0
    • Fix Version/s: 6.1
    • Component/s: None
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      3
    • Documentation Status:
      Not Required

      Description

      The grunt-contrib-handlebars dependency in package.json was updated to version 1.0.0 in ticket DS-3315. This version of grunt-contrib-handlebars uses handlebars version 4.0.0 to compile the templates, which causes conflicts with the handlebars version 2.0.0 used by Mirage2

      This issue can be resolved by going back to grunt-contrib-handlebars version 0.9.3. This version is compatible with handlebars version 2.0.0.

      During the npm build this will cause the following peer dependency warning to be shown, but this is simply because the dependency on the grunt version was configured too strict in that version of grunt-contrib-handlebars.
      It does work correctly:
      npm WARN grunt-contrib-handlebars@0.9.3 requires a peer of grunt@~0.4.0 but none was installed

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                philipatmire Philip Vissenaekens (Atmire)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: