Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-3536

Update DSpace lib versions to align with RTS

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Volunteer Needed (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 7.0
    • Component/s: Replication Task Suite
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      3
    • Documentation Status:
      Not Required

      Description

      As noted in the PR for DS-3389, when compiling with the latest version of RTS, there is a dependency convergence issue because RTS brings in some libraries (via DuraCloud), which are newer than those declared in the DSpace poms.

      This can be worked around by manually adding those libs as exclusions in additions' pom. However, the ideal solution here is to ensure DSpace's dependencies are kept in line with those brought in from RTS (transitively or not).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              cwilper Chris Wilper
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: