Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-3695

Solr needs to be upgraded, Solr 4 is EOL

    Details

    • Type: Code Task
    • Status: Code Review Needed (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Affects Version/s: 6.2
    • Fix Version/s: 7.0
    • Component/s: Solr
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      9
    • Documentation Status:
      Needed

      Description

      Apache Solr 6.0.0 is available since April 2016. Currently Apache Solr claims to support the previous major versions with bug and security fixes (http://lucene.apache.org/solr/community.html). Following that scheme Solr 4.x which we use in DSpace is EOL.

      Solr 4 was the last version of solr that supported the integration as war. Every version of solr after 5.0.0 is provided as standalone application. That means we probably won't be able to ship solr as a DSpace module anymore, but have to include it into the list of requirements.

      I'm not sure if we should upgrade SOLR in DSpace 7.0 only or if we should backport an upgrade to older versions of DSpace too. While we ship solr with a filter that restricts access to solr to localhost, solr will always parse search and browse queries which are influenced by DSpace's enduser.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                terrywbrady Terry Brady
                Reporter:
                pbecker Pascal-Nicolas Becker
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: