Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-4041

Update to using Servlet Spec 3.1.0 in dependencies

    XMLWordPrintable

    Details

    • Type: Code Task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 7.0
    • Fix Version/s: 7.0
    • Component/s: DSpace API
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      6
    • Documentation Status:
      Complete or Committed

      Description

      Currently, on "master" we are inconsistent about our usage of Servlet Spec.  The Parent POM declares we use v2.5, while both REST APIs require v3.1.0.

      We should standardize on using 3.1.0. 

      However, This will require using Tomcat 8 or above. See http://tomcat.apache.org/whichversion.html

      PR coming soon.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                tdonohue Tim Donohue
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: