Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-407

Install or Upgrade on existing server throws errors for "mvn package"

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.0
    • Fix Version/s: 1.6.0
    • Component/s: Documentation
    • Labels:
      None
    • Environment:
      Any
    • Attachments:
      0
    • Comments:
      2
    • Documentation Status:
      Complete or Committed

      Description

      (1) Login to a server where DSpace 1.5.x has been previously installed (and therefore all the DSpace maven modules will have been cached in your ~/.m2/ local repository)

      (2) Do a fresh install or an upgrade. In both cases, it recommends to run "mvn package"

      However, running "mvn package" will give an error similar to:

      Couldn't find a version in [1.5.0.0, 1.5.2.0, 1.5.2.1] to match range [1.6.0.0,1.7.0.0) org.dspace:dspace-api-lang:jar:null .

      The problem seems to be that Maven by default doesn't go out to the web to look for the latest version of "dspace-api-lang" or "dspace-xmlui-lang". Instead, it looks only in your ~/.m2/ directory, and only finds 1.5.x versions there.

      The fix seems to be to recommend running "mvn -U package". The -U option forces Maven to check for updates out on the web.

      Does anyone have a better/cleaner solution, or should we change our Install/Upgrade docs to say "mvn -U pcakge"?

        Attachments

          Activity

            People

            • Assignee:
              jtrimble Jeffrey Trimble
              Reporter:
              tdonohue Tim Donohue
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: