Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-4351

Upgrade spring (boot) & hibernate to newer versions

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Accepted / Claimed (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 7.0
    • Fix Version/s: 7.0
    • Component/s: DSpace API, REST API v7
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      1
    • Documentation Status:
      Not Required

      Description

      The current Rest 7 codebase relies on spring 4.3, spring boot 1.4 & hibernate 5.2, these are from 2016 / 2017 respectively.
      We should upgrade to more recent stable versions.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kevin van de velde Kevin Van de Velde (Atmire)
              Reporter:
              kevin van de velde Kevin Van de Velde (Atmire)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: