DSpace
  1. DSpace
  2. DS-618

Recommended versions of prerequisites becoming outdated

    Details

    • Type: Task Task
    • Status: Closed Closed (View Workflow)
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.7.0
    • Component/s: Documentation
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      12

      Description

      We still recommend at least "PostgreSQL 7.3 or 7.4". 7.4 is now seven years old and losing maintainer support next month (or so). By December only 8.2 and up will be supported.

      Sun Java 5 SE reaches its End Of Service Life in October 2010.

      Maven 2.2 is current. We might recommend at least 2.0.11 (the current "older release") rather than 2.0.8.

      Tomcat 4 is positively ancient and definitely unsupported by its maintainers. Even 5.0 is too old for help. 5.5 should be our minimum recommendation.

      Please discuss.

        Activity

        Hide
        Robin Taylor added a comment -
        Hi Mark, sorry about the Pom confusion, misuse of the word 'dependencies' on my part. What I should have said was that the sooner we update the <source> and <target> elements in the Pom to be 1.6, so much the better.

        Cheers, Robin
        Show
        Robin Taylor added a comment - Hi Mark, sorry about the Pom confusion, misuse of the word 'dependencies' on my part. What I should have said was that the sooner we update the <source> and <target> elements in the Pom to be 1.6, so much the better. Cheers, Robin
        Hide
        Tim Donohue added a comment -
        Changed the main DSpace pom.xml to now require Java 1.6. We just need to document this as the new prerequisite in DSpace 1.7
        Show
        Tim Donohue added a comment - Changed the main DSpace pom.xml to now require Java 1.6. We just need to document this as the new prerequisite in DSpace 1.7
        Hide
        Mark H. Wood added a comment -
        I will suggest these recommendations:

        Java: 1.6 minimum. (DSpace 1.7 depends on Java 1.6 features.)
        Maven: 2.0.8 minimum, 2.2 suggested (Debian stable is still at 2.0.9, might as well leave the minimum alone)
        Ant: 1.7 minimum, 1.8 okay (again, Debian at 1.7)
        PostgreSQL: 8.1 minimum, suggest 8.2-8.4 (9.0 is very new)
        Oracle: does anyone have an opinion about Oracle versions?
        Tomcat: 5.5 minimum, 6 suggested

        We have made no recommendations for Jetty, Resin, or Perl, all of which are mentioned. Do we want any? There is some movement to remove Perl as a prerequisite -- is this completed? Do we want to replace mention of Jetty and/or Resin with a more generic "other servlet containers work too"?

        Our actual requirement is for a servlet container and (optionally) JSP engine, supporting recent enough versions of the Servlet and JSP specifications, with Tomcat 5.5-6.0 typical. Do we want to reword that bit, and perhaps move specific implementations' versions and configuration elsewhere?
        Show
        Mark H. Wood added a comment - I will suggest these recommendations: Java: 1.6 minimum. (DSpace 1.7 depends on Java 1.6 features.) Maven: 2.0.8 minimum, 2.2 suggested (Debian stable is still at 2.0.9, might as well leave the minimum alone) Ant: 1.7 minimum, 1.8 okay (again, Debian at 1.7) PostgreSQL: 8.1 minimum, suggest 8.2-8.4 (9.0 is very new) Oracle: does anyone have an opinion about Oracle versions? Tomcat: 5.5 minimum, 6 suggested We have made no recommendations for Jetty, Resin, or Perl, all of which are mentioned. Do we want any? There is some movement to remove Perl as a prerequisite -- is this completed? Do we want to replace mention of Jetty and/or Resin with a more generic "other servlet containers work too"? Our actual requirement is for a servlet container and (optionally) JSP engine, supporting recent enough versions of the Servlet and JSP specifications, with Tomcat 5.5-6.0 typical. Do we want to reword that bit, and perhaps move specific implementations' versions and configuration elsewhere?
        Hide
        Mark H. Wood added a comment -
        From 13-Oct-2010 IRC meeting, concerning Oracle versions to recommend:
        (17:07:01) HardyPottinger: word from our DBA is: "I would recommend nothing less than 10g, and preferably 11g. 9i support will soon be deprecated, and if they can support 11 it would be best to do that as the lifespan will be the longest"

        I will suggest that we recommend:

        Oracle: 10g minimum, suggest 11.
        Show
        Mark H. Wood added a comment - From 13-Oct-2010 IRC meeting, concerning Oracle versions to recommend: (17:07:01) HardyPottinger: word from our DBA is: "I would recommend nothing less than 10g, and preferably 11g. 9i support will soon be deprecated, and if they can support 11 it would be best to do that as the lifespan will be the longest" I will suggest that we recommend: Oracle: 10g minimum, suggest 11.
        Hide
        Mark H. Wood added a comment -
        I've updated the documentation on the wiki. There was some strange-looking markup that looked like it didn't transfer properly and I patched it up in the areas where I was working, but I'm brand-new to Confluence markup and hope I didn't botch something that I didn't understand.
        Show
        Mark H. Wood added a comment - I've updated the documentation on the wiki. There was some strange-looking markup that looked like it didn't transfer properly and I patched it up in the areas where I was working, but I'm brand-new to Confluence markup and hope I didn't botch something that I didn't understand.

          People

          • Assignee:
            Mark H. Wood
            Reporter:
            Mark H. Wood
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: