Uploaded image for project: 'DSpace'
  1. DSpace
  2. DS-980

Upgraded solr & lucene to version 3.3.0

    Details

    • Attachments:
      3
    • Comments:
      20
    • Documentation Status:
      Needed

      Description

      Since DSpace is still using solr 1.4.x & lucene 2.9.3 I have created a patch that will upgrade these to version 3.3.0 (Lucene & solr have received matching version numbers).

      Since the dspace solr also requires a LocalHostRestrictionFilter I have created a dspace-solr module with version 3.3.0.0 at the following location: http://scm.dspace.org/svn/repo/modules/dspace-solr/branches/dspace-solr-parent-3.3.0.0
      Because of the new dspace-solr module a local installation of this module is required to actually test the patch (once the patch has been tested this module will need to be deployed).

      Also a thing to note, the solr upgrade just required updating the poms, but for Lucene some code had to be rewritten some extra eyes on this wouldn't hurt (although the tests I performed have been successful).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tdonohue Tim Donohue
                Reporter:
                kevin van de velde Kevin Van de Velde (Atmire)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: