Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: Fedora 4.3.0
    • Fix Version/s: None
    • Component/s: f4-core
    • Labels:
    • Sprint:
      Sprint 2016 - 18

      Description

      The fedora http modules rely on both javax.ws.rs.core and javax.servlet.http classes. It seems to make sense to consolidate these around javax.ws.rs.core

      Also, the metrics module depends on a javax.servlet.annotation class. We should evaluate whether this is necessary.

      At present, the maven configuration downgrades the servlet-api version to 3.0.1 (even though modeshape depends on 3.1.0). This causes some messiness for OSGi, and it would be good to straighten this out. (Removing the direct dependency may be the easiest approach)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                acoburn Aaron Coburn
                Reporter:
                acoburn Aaron Coburn
                Reviewer:
                Andrew Woods
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: