Uploaded image for project: 'VIVO'
  1. VIVO
  2. VIVO-1483

VIVO hangs on startup after upgrading using jena3tools

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.10
    • Component/s: Data Management
    • Labels:
      None
    • Attachments:
      1
    • Comments:
      20
    • Sprint:
      VIVO Sprint 1, VIVO Sprint 2

      Description

      VIVO hangs on startup after upgrading the database to Jena 3.

      You can try to replicate the problem by downloading my home directory: home.zip

      Jena 2 dumps are already included in the directory. 

      Delete your MySQL database for VIVO: 
      DROP DATABASE <vivodb>; CREATE DATABASE <vivodb> CHARACTER SET utf8mb4; GRANT ALL ON <vivodb>.* TO '<user>'@'localhost';

      Delete <vivo-home>/tdbModels (shouldn't exist unless you copied over an existing vivo home directory.

      Run jena3tools
      java jar jena3tools.jar d <vivo home dir> -i-

      Start up VIVO (develop branch) 

      I don't get an error, but startup hangs and these are the last lines in the log:

      2018-04-26 15:29:28,565 INFO  [FileGraphSetup] Updating /usr/local/vivodev/home/rdf/abox/filegraph/geopolitical.abox.ver1.1-11-18-11.owl because graphs are not isomorphic
      
      2018-04-26 15:29:28,733 INFO  [FileGraphSetup] dbModel: 22317 ; fileModel: 22317

      I'm running OS X with MySQL.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mbgross Benjamin Gross
                Reporter:
                mbgross Benjamin Gross
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: