Uploaded image for project: 'VIVO'
  1. VIVO
  2. VIVO-1486

Update mysql-connector-java dependency in jenatools to 8.0.11

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.10
    • Component/s: Dependencies
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      2
    • Sprint:
      VIVO Sprint 1, VIVO Sprint 2

      Description

      Since we are upgrading mysql-connector-java in Vitro to 8.0.11, we should update jenatools to use the same. The 8.0.11 connector is required if a user has the latest MySQL version installed (8.0.11). 

      Note, simply changing the dependency version in the pom.xml files results in a couple warnings, but the tools still work.

      Loading class `com.mysql.jdbc.Driver'. This is deprecated. The new driver class is `com.mysql.cj.jdbc.Driver'. The driver is automatically registered via the SPI and manual loading of the driver class is generally unnecessary.
      
      Fri Apr 27 14:37:30 MDT 2018 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mbgross Benjamin Gross
                Reporter:
                mbgross Benjamin Gross
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: