Uploaded image for project: 'VIVO'
  1. VIVO
  2. VIVO-554

Adding and editing roles from receiving (not the person) side has problems

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.6
    • Component/s: Custom forms
    • Labels:
      None
    • Attachments:
      0
    • Comments:
      1

      Description

      In testing data entry based on what I've had to do this week for Kizer Walker and Signale, a publication series, I found several hopefully minor issues.
      I'm not sure it makes sense to add roles from the receiving side vs. from the person or actor in the role – the forms let me pick from any other role already in VIVO, while roles are not intended to be re-used. For example, I was able to pick an existing role for another person relative to another organization and connect it to this publication series.
      There was also a problem in adding a contributor or editor role – the role displayed correctly from the person and the series, but when I went to edit it, there was no label so the local name was offered for editing – the "Editor" label appearing in the list view had apparently not been populated as a label for the role. When I added a label, it did then display correctly.
      I can demonstrate the issues if it would be helpful.

        Attachments

          Activity

            People

            • Assignee:
              tlw72 Tim Worrall
              Reporter:
              jc55 Jon Corson-Rikert
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: